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TerraSonde reserves the right to make changes in specifications and other information contained in this
publication without prior notice, and the reader should in all cases consult TerraSonde to determine
whether any such changes have been made. This manual may not be reproduced, and is intended for the
exclusive use of TerraSonde users.

The terms and conditions governing the sale and use of the TerraLink software program consist solely of
those set forth in the written contracts between TerraSonde and its customers. No statement contained in
this publication, including statements regarding capacity, suitability for use, or performance of products,
shall be considered a warranty by TerraSonde for any purpose or give rise to any liability of TerraSonde.

In no event will TerraSonde be liable for any incidental, indirect, special, or consequential damages
(including lost profits) arising out of or relating to this publication or the information contained in it, even
TerraSonde has been advised, knew, or should have known of the possibility of such damages.

The TerraLink program described in this document is copyrighted and is confidential information and a
proprietary product of TerraSonde. The copyright laws prohibit the copying of this manual or any of the
support software programs without the written consent of TerraSonde, except in the normal use of the
product, or to make a backup copy. This exception does not allow a copy to be made for others. Copying,
under the law, includes translating into another language or format.

(c) Copyright 2002,2003    All Rights Reserved
TerraSonde
2434 30th Street
Boulder, CO  80301
USA
(303) 545-5848      FAX (303) 545-6066
www.terrasonde.com

All rights reserved.
Printed in USA
Revised: January, 03

General Notice: some of the product names used herein have been used for identification purposes only
and may be trademarks of their respective companies.

The Audio Toolbox is a trademark of TerraSonde.
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Quick Start
No time for manuals? Read this section to jump-start TerraLink!
Ø Install it. On the Mac, just copy the TerraLink folder to your hard disk. Then run the

TerraLink program. On the PC, run the Install program.
Ø Connect the Toolbox. Plug the Toolbox computer interface cable into the MIDI in and

Out ports on the Toolbox, and into the computer’s serial port. Most Macs require a USB
to serial interface device.

Ø Enter the Registration code. A registration code is required to fully use TerraLink. If
you do not have a registration code, you will be able to run a the program as a viewer.
To enter the code, use the Registration Codes function on the Edit menu.

Ø Play around. Since you don’t like manuals, just try on your own. It’s pretty easy. Just
know that basically, you will open a new project, and Upload the memories from the
Toolbox. Or, if you don’t have a registration code, just open the example file. The rest
should be obvious. For the real-time interface, just run that function after selecting a
port. The Toolbox will need to be in the RTA, FFT, or Energy-Time Graph function.

Ø But I want to do more… Well, read on. You will learn how to cut and paste project
files, save multiple project files, store them back into the Toolbox, do advanced graphing
and math tricks, and print graphs.

Computer Requirements
An Apple power PC running OS 8.5 to OS 9.2 is required. If you are running OS X, you will
need to run TerraLink in Classic mode.

Serial Communications
Apple computers are no longer made with serial ports, so a USB to Serial adapter is required
to used TerraLink on a Mac (and on some PCs). We have tested several interfaces and have
had good luck with the single serial port versions of the Belkin brand of adapters.
Also, a copy of the Serial Tool (a Mac operating system component) is required to use this
program. If your Mac does not have the Serial Tool installed in the System folder, you can
download a copy of one from the Apple web site, or contact us for a copy. (They are free).

Registration Codes
TerraLink uses Registration Codes as a means of licensing the software. If you do not have a
Registration Code, the program will work as a viewer. Also, the functions that interact with a
Toolbox will only work if a Registration Code was obtained for that Toolbox. Separate
Registration Codes are required for every Toolbox that you wish to work with.
Registration codes are stored on the computer’s hard disk, in a preference file (Mac) or the
Registry (PC). You can purchase as many Registration Codes as you wish, if you need to
work with more than one Toolbox. You can install TerraLink on as many computers as you
like, and as long as you have the correct Registration Codes it will communicate with the
connected Toolbox.
If the software is un-registered, you will be able to open Project Files and examine graphs,
and print, but you will not be able to create or save Project Files, or communicate with a
Toolbox (upload or download memories or use the real-time interface). You can send the
TerraLink program to a client with your project file so that the client can view and print data.
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Note that the registration codes are also stored in the preference file, so if you delete it, you
will need to re-enter the codes.

Preferences
TerraLink stores a set of preferences in a normal Apple preference file. This file can be found
in the Preference folder in the System Folder.

Serial Connection
You need to set the serial connection before using TerraLink. If you do not set it, you will be
prompted to set it. This setting will be stored in the preference file.

Colors
Screen colors can be set and stored here.

User Information
You can enter information about your company and the project that will be printed on each
graph.
You can enter a company name and address, phone number, person’s name, project (or
customer) name.
You can also select whether or not to print the current date and time on the graph.

Project Files
The basis for TerraLink is the Project File. A Project File can hold 40 memories (just like a
Toolbox). Usually, you will start a new Project File, load the memories from a Toolbox, and
go from there. You can save the file to your hard disk, email it to someone else, and store it
back into your Toolbox or a different Toolbox.
You can open several Project Files at once, and cut, copy and paste memories from one to
another, creating a Project File that is a composite of memories created at different times,
even from different Toolboxes.
In some cases you can sum several graphs of the same type and store the results back into
the Project File as a new memory. This memory can then be used as the basis for a
difference mode display.
You can also capture real-time data into a memory and copy the new memory into a Project
File.

Manipulating Project Files

The Project Tab
Each open Project File window contains a Project tab. This is the place where you can modify
the project file’s contents.
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Project Tab Screen
The first thing you will probably want to do is to get the memories from the Toolbox into
TerraLink.

Importing Memories
To import memories into a project file:
Ø Connect the Toolbox to the Mac using the TerraSonde interface cable
Ø Change to the Computer Interface function on the Toolbox Utilities menu
Ø If you have not yet selected your serial port connection, open the Preferences file on the

Edit menu, and select your serial connection
Ø On the Mac, select File, New to create a new empty project file
Ø Click on the Projects tab to bring it to the front
Ø Click on the Import All button to transfer all 40 memories from the Toolbox to the project

file, or click on Import to transfer only one memory.
Once the memories have been transferred into the Project File, you can click on the tabs to
view the memories.
You can rename individual memories with descriptive tags, re-order the memories in the file,
and delete memories. To make it easier to work with multiple Project Files, you can close the
graph window on the lower part of the Project File Window while leaving the upper part of
the window open. Thus, each Project File will take up the least room on the screen.
To move or copy memories from one Project File to another, just open both Project Files (to
get two Project File windows), select the Project tabs, and use the mouse to drag memories
from one file to another. Note that you must have room in the destination Project File, so
you may need to delete memories from it if the file is full.
Or, create a New Project File, and drag memories from other Project File windows into the
new Project File to make a new Project File.
The memories from any Project File can be transferred to a Toolbox by using the Export
Memories button on the Project Tab.

Exporting Memories
To export the memories from a project file to a Toolbox:
Ø Connect the Toolbox to the Mac using the TerraSonde interface cable
Ø Change to the Computer Interface function on the Toolbox Utilities menu
Ø If you have not yet selected your serial port connection, open the Preferences file on the

Edit menu, and select your serial connection
Ø On the Mac, click on the Projects tab to bring it to the front
Ø Click on the Export All button to export all 40 memories, or click on Export to transfer

one specific memory to the Toolbox.
The memories will be transferred into the Toolbox and will be available for recall in the
functions.

Tools available to all graphs
The Tools available for each graph vary, but some tools are used by all graphs. These are:

Edit Colors Tool
This tool pops open a window that lets you change the color of any of the graphs on the
screen.
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Graph Scale & Range
To change the vertical graph scale, use the scrollbar on the left of the window to drag the
graph up and down, and use the small arrows at the top of the scrollbar to change the range
(max and min) of the graph. You can also change the grid to show lines every 10 dB, 5 dB,
or 1 dB.

Zooming
Selecting the + magnify tool lets you use the cursor to draw a box around an area that will
become the new graph area. This lets you zoom in to examine any part of the graph in
detail. To get the graph back to full size, click the – magnify tool.

Readout Cursor
Selecting the Readout Cursor (Large +) lets you click on points on the graph and display the
actual values of those points in the data window.

Print Tool
To print the current graph, just click the Print tool. Note that graphs are always printed
without the Readout Cursor, fully zoomed out.

The Real Time Analyzer Tab
To look at the RTA memories in the Project File, click the RTA tab. Now, use the Select
Memories button to see a list of all RTA memories in the Project File. If you click on the
memory name, a check mark will appear in front of the memory name, and the graph will be
displayed on the screen. Click again to remove the check mark and erase the graph from the
screen.
You can display as many RTA graphs as you like on the screen. Each will show up in a new
color.

Average Tool
Select the Average Tool (looks like a summation symbol) to algebraically average all of the
graphs currently being shown. Note that since this is a true algebraic average, 60 dB and 80
dB do NOT average to 70 dB.
The resulting average curve may be stored as a new memory by using the Copy function on
the Edit menu.

Difference Tool
Selecting the Difference Tool (looks like a large minus sign) lets you see how one or more
graphs compare to a reference graph. The reference graph is selected on the pull-down
menu to the left of the Difference Tool button. In this case, as is customarily done, the
difference is in dB, so 70 dB minus 60 dB is 10 dB.
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The FFT Analyzer Tab
Selecting this tab allows you to see any of the FFT graphs that are members of this Project
File. Use the Select Memory button to display or erase memories from the screen.
You can display as many FFT graphs as you like on the screen. Each will show up in a new
color. You can change the colors of each graph by clicking on the Edit Colors button.

FFT Analyzer Screen

Graph Type
You can select between 7 different graph formats for viewing the FFT data. These include
the normal octave, 1/3 octave, 1/6 octave, and 1/12 octave bars that are the same as the
bars seen on the Toolbox screen, as well as octave, 1/3 octave, and 1/12 octave graphs that
have been curve-fit and smoothed. The curve-fit algorithm used is a spline, with as many
output points as there are points on the zoomed-out screen.
The bars are created using algebraic summing (as on the Toolbox), so as you consolidate the
data more, the level of the bar will rise. The curves that are drawn always use the 1/12
octave data, so they do not rise as the smoothing is increased.

Average Tool
Select the Average Tool (looks like a summation symbol) to algebraically average all of the
graphs currently being shown. Note that since this is a true algebraic average, 60 dB and 80
dB do NOT average to 70 dB.



9

                         TERRALINK

The resulting average curve may be stored as a new memory by using the Copy command
on the Edit menu.

Difference Tool
Selecting the Difference Tool (looks like a large minus sign) lets you see how one or more
graphs compare to a reference graph. The reference graph is selected on the pull-down
menu to the left of the Difference Tool button. In this case, as is customarily done, the
difference is in dB, so 70 dB minus 60 dB is 10 dB.

The Sound Study Graph Tab
This tab selects the Sound Study Graphs stored in the Project File. You can only display one
Sound Study Graph at a time. Along with the standard tools, you can also use the Set Start
Time tool.

Set Start Time
This tool lets you enter a start time of day for the graph, so that all times on the graph are
shown relative to this time.

The Energy Time Graph Tab
You can see any Energy Time Graphs that are stored in the Project File with this tab. Only
one ETG can be viewed at a time. There is one special tool available.

RT60 Tool
If you select the RT60 Tool (looks like a slanting line) you can set the 2 endpoints of a line
that represents a slope on the ETG. This slope is translated to an equivalent RT60 time and
the time is displayed in the data box. Printing the graph will print these lines and the RT60
time.

The Sweeps Tab
This tab shows the stored amplitude and impedance graphs. You can view multiple sweep
graphs (of the same type) at the same time on the screen.

Average Tool
Select the Average Tool (looks like a summation symbol) to algebraically average all of the
graphs currently being shown. Note that since this is a true algebraic average, 60 dB and 70
dB do NOT average to 65 dB. Impedance curves are averaged numerically in ohms.
The resulting average curve may be stored as a new memory.

Difference Tool
Selecting the Difference Tool (looks like a large minus sign) lets you see how one or more
graphs compare to a reference graph. The reference graph is selected on the pull-down
menu to the left of the Difference Tool button. In this case, as is customarily done, the
difference is in dB, so 70 dB minus 60 dB is 10 dB.

Real-Time Interface
TerraLink provides a real-time interface that displays the RTA, FFT, and Energy Time graphs
on the computer screen as the function is running on the Toolbox.
To use this feature, with the Toolbox connected to the computer, select the desired serial
port, and then run the Real Time Interface function, from the ATB Link menu. Then run any
of the supported functions on the Toolbox, and click the GO button on the computer screen,
in the Real Time Interface window. You should start to see the computer graph immediately
displaying the graphical data from the Toolbox.
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This TerraLink screen is updated every time that the Toolbox screen is updated, and is
smoothed between Toolbox updates with extrapolated data.
To freeze the display, click the Stop button.
You can use the Copy function on the Edit menu at any time (stopped or running) to store
the current memory data on the clipboard. Then you can switch to any open Project File
window and use the Paste function on the Edit menu to paste that memory into that Project
File, as long as there is space available in the Project File.
The Real Time Interface window has these tools available:

Graph Scale & Range
To change the graph scale, use the scrollbar on the left of the window to drag the graph up
and down, and use the small arrows at the top of the scrollbar to change the range (max
and min) of the graph. You can change the grid to show lines every 10 dB, 5 dB, or 1 dB.

Zooming
Selecting the + magnify tool lets you use the cursor to draw a box around an area that will
become the new graph area. This lets you zoom in to examine any part of the graph in
detail. To get the graph back to full size, click the – magnify tool.

Readout Cursor
Select the Readout Cursor (Large +) lets you click on points on the graph and display the
actual values of those points in the data window.

Print Tool
To print the current graph, just click the Print tool. Note that graphs are always printed
without the Readout Cursor, fully zoomed out.


